ALAS-2021-1479


Amazon Linux AMI Security Advisory: ALAS-2021-1479
Advisory Release Date: 2021-02-16 00:13 Pacific
Advisory Updated Date: 2021-02-16 22:38 Pacific
Severity: Important
References: CVE-2020-29599 

Issue Overview:

A flaw was found in ImageMagick. The -authenticate option is mishandled allowing user-controlled password set for a PDF file to possibly inject additional shell commands via coders/pdf.c. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2020-29599 )


Affected Packages:

ImageMagick


Issue Correction:
Run yum update ImageMagick to update your system.

New Packages:
i686:
    ImageMagick-c++-devel-6.9.10.68-3.23.amzn1.i686
    ImageMagick-perl-6.9.10.68-3.23.amzn1.i686
    ImageMagick-devel-6.9.10.68-3.23.amzn1.i686
    ImageMagick-6.9.10.68-3.23.amzn1.i686
    ImageMagick-c++-6.9.10.68-3.23.amzn1.i686
    ImageMagick-debuginfo-6.9.10.68-3.23.amzn1.i686
    ImageMagick-doc-6.9.10.68-3.23.amzn1.i686

src:
    ImageMagick-6.9.10.68-3.23.amzn1.src

x86_64:
    ImageMagick-6.9.10.68-3.23.amzn1.x86_64
    ImageMagick-devel-6.9.10.68-3.23.amzn1.x86_64
    ImageMagick-doc-6.9.10.68-3.23.amzn1.x86_64
    ImageMagick-c++-devel-6.9.10.68-3.23.amzn1.x86_64
    ImageMagick-debuginfo-6.9.10.68-3.23.amzn1.x86_64
    ImageMagick-c++-6.9.10.68-3.23.amzn1.x86_64
    ImageMagick-perl-6.9.10.68-3.23.amzn1.x86_64