ALAS-2021-1489


Amazon Linux AMI Security Advisory: ALAS-2021-1489
Advisory Release Date: 2021-03-18 17:30 Pacific
Advisory Updated Date: 2021-03-19 22:55 Pacific
Severity: Important
References: CVE-2021-27135 

Issue Overview:

A flaw was found in xterm. A specially crafted sequence of combining characters causes an out of bounds write leading to arbitrary code execution. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. (CVE-2021-27135)


Affected Packages:

xterm


Issue Correction:
Run yum update xterm to update your system.

New Packages:
i686:
    xterm-295-3.15.amzn1.i686
    xterm-debuginfo-295-3.15.amzn1.i686

src:
    xterm-295-3.15.amzn1.src

x86_64:
    xterm-295-3.15.amzn1.x86_64
    xterm-debuginfo-295-3.15.amzn1.x86_64