ALAS-2021-1494


Amazon Linux AMI Security Advisory: ALAS-2021-1494
Advisory Release Date: 2021-04-19 17:26 Pacific
Advisory Updated Date: 2021-04-21 17:50 Pacific
Severity: Important
References: CVE-2021-20277 

Issue Overview:

A flaw was found in Samba's libldb. Multiple, consecutive leading spaces in an LDAP attribute can lead to an out-of-bounds memory write, leading to a crash of the LDAP server process handling the request. The highest threat from this vulnerability is to system availability. (CVE-2021-20277)


Affected Packages:

libldb


Issue Correction:
Run yum update libldb to update your system.

New Packages:
i686:
    libldb-1.5.4-2.17.amzn1.i686
    libldb-devel-1.5.4-2.17.amzn1.i686
    pyldb-1.5.4-2.17.amzn1.i686
    libldb-debuginfo-1.5.4-2.17.amzn1.i686
    pyldb-devel-1.5.4-2.17.amzn1.i686
    ldb-tools-1.5.4-2.17.amzn1.i686

src:
    libldb-1.5.4-2.17.amzn1.src

x86_64:
    libldb-1.5.4-2.17.amzn1.x86_64
    pyldb-devel-1.5.4-2.17.amzn1.x86_64
    pyldb-1.5.4-2.17.amzn1.x86_64
    libldb-debuginfo-1.5.4-2.17.amzn1.x86_64
    libldb-devel-1.5.4-2.17.amzn1.x86_64
    ldb-tools-1.5.4-2.17.amzn1.x86_64