ALAS-2021-1504


Amazon Linux AMI Security Advisory: ALAS-2021-1504
Advisory Release Date: 2021-05-20 21:12 Pacific
Advisory Updated Date: 2021-05-21 18:50 Pacific
Severity: Low

Issue Overview:

The package python/cpython is vulnerable to Web Cache Poisoning via urllib.parse.parse_qsl and urllib.parse.parse_qs by using a vector called parameter cloaking. When the attacker can separate query parameters using a semicolon (;), they can cause a difference in the interpretation of the request between the proxy (running with default configuration) and the server. This can result in malicious requests being cached as completely safe ones, as the proxy would usually not see the semicolon as a separator, and therefore would not include it in a cache key of an unkeyed parameter. (CVE-2021-23336 )

There's a flaw in Python 3's pydoc. A local or adjacent attacker who discovers or is able to convince another local or adjacent user to start a pydoc server could access the server and use it to disclose sensitive information belonging to the other user that they would not normally be able to access. The highest risk of this flaw is to data confidentiality. This flaw affects Python versions before 3.8.9, Python versions before 3.9.3 and Python versions before 3.10.0a7. (CVE-2021-3426 )


Affected Packages:

python34


Issue Correction:
Run yum update python34 to update your system.

New Packages:
i686:
    python34-tools-3.4.10-1.55.amzn1.i686
    python34-debuginfo-3.4.10-1.55.amzn1.i686
    python34-test-3.4.10-1.55.amzn1.i686
    python34-libs-3.4.10-1.55.amzn1.i686
    python34-3.4.10-1.55.amzn1.i686
    python34-devel-3.4.10-1.55.amzn1.i686

src:
    python34-3.4.10-1.55.amzn1.src

x86_64:
    python34-debuginfo-3.4.10-1.55.amzn1.x86_64
    python34-tools-3.4.10-1.55.amzn1.x86_64
    python34-devel-3.4.10-1.55.amzn1.x86_64
    python34-3.4.10-1.55.amzn1.x86_64
    python34-libs-3.4.10-1.55.amzn1.x86_64
    python34-test-3.4.10-1.55.amzn1.x86_64