ALAS-2021-1517


Amazon Linux AMI Security Advisory: ALAS-2021-1517
Advisory Release Date: 2021-07-08 18:38 Pacific
Advisory Updated Date: 2021-07-12 21:51 Pacific
Severity: Important
References: CVE-2021-31535 

Issue Overview:

A missing validation flaw was found in libX11. This flaw allows an attacker to inject X11 protocol commands on X clients, and in some cases, also bypass, authenticate (via injection of control characters), or potentially execute arbitrary code with permissions of the application compiled with libX11. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. (CVE-2021-31535)


Affected Packages:

libX11


Issue Correction:
Run yum update libX11 to update your system.

New Packages:
i686:
    libX11-common-1.6.0-2.2.14.amzn1.i686
    libX11-1.6.0-2.2.14.amzn1.i686
    libX11-devel-1.6.0-2.2.14.amzn1.i686
    libX11-debuginfo-1.6.0-2.2.14.amzn1.i686

src:
    libX11-1.6.0-2.2.14.amzn1.src

x86_64:
    libX11-1.6.0-2.2.14.amzn1.x86_64
    libX11-common-1.6.0-2.2.14.amzn1.x86_64
    libX11-devel-1.6.0-2.2.14.amzn1.x86_64
    libX11-debuginfo-1.6.0-2.2.14.amzn1.x86_64