ALAS-2021-1520


Amazon Linux AMI Security Advisory: ALAS-2021-1520
Advisory Release Date: 2021-07-08 18:38 Pacific
Advisory Updated Date: 2021-07-12 21:52 Pacific
Severity: Important
References: CVE-2021-32027 

Issue Overview:

A flaw was found in postgresql. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2021-32027)


Affected Packages:

postgresql96


Issue Correction:
Run yum update postgresql96 to update your system.

New Packages:
i686:
    postgresql96-9.6.22-1.85.amzn1.i686
    postgresql96-devel-9.6.22-1.85.amzn1.i686
    postgresql96-libs-9.6.22-1.85.amzn1.i686
    postgresql96-debuginfo-9.6.22-1.85.amzn1.i686
    postgresql96-contrib-9.6.22-1.85.amzn1.i686
    postgresql96-plpython26-9.6.22-1.85.amzn1.i686
    postgresql96-plpython27-9.6.22-1.85.amzn1.i686
    postgresql96-docs-9.6.22-1.85.amzn1.i686
    postgresql96-server-9.6.22-1.85.amzn1.i686
    postgresql96-plperl-9.6.22-1.85.amzn1.i686
    postgresql96-test-9.6.22-1.85.amzn1.i686
    postgresql96-static-9.6.22-1.85.amzn1.i686

src:
    postgresql96-9.6.22-1.85.amzn1.src

x86_64:
    postgresql96-plpython27-9.6.22-1.85.amzn1.x86_64
    postgresql96-contrib-9.6.22-1.85.amzn1.x86_64
    postgresql96-9.6.22-1.85.amzn1.x86_64
    postgresql96-debuginfo-9.6.22-1.85.amzn1.x86_64
    postgresql96-libs-9.6.22-1.85.amzn1.x86_64
    postgresql96-static-9.6.22-1.85.amzn1.x86_64
    postgresql96-plpython26-9.6.22-1.85.amzn1.x86_64
    postgresql96-devel-9.6.22-1.85.amzn1.x86_64
    postgresql96-test-9.6.22-1.85.amzn1.x86_64
    postgresql96-plperl-9.6.22-1.85.amzn1.x86_64
    postgresql96-server-9.6.22-1.85.amzn1.x86_64
    postgresql96-docs-9.6.22-1.85.amzn1.x86_64