ALAS-2021-1523


Amazon Linux AMI Security Advisory: ALAS-2021-1523
Advisory Release Date: 2021-07-19 17:29 Pacific
Advisory Updated Date: 2021-07-21 18:30 Pacific
Severity: Medium
References: CVE-2021-32760 

Issue Overview:

A bug was discovered in containerd where pulling and extracting a specially-crafted container image can result in Unix file permission changes for existing files in the host's filesystem. Changes to file permissions can deny access to the expected owner of the file or widen access to others. (CVE-2021-32760)


Affected Packages:

containerd


Issue Correction:
Run yum update containerd to update your system.

New Packages:
src:
    containerd-1.4.6-2.7.amzn1.src

x86_64:
    containerd-stress-1.4.6-2.7.amzn1.x86_64
    containerd-debuginfo-1.4.6-2.7.amzn1.x86_64
    containerd-1.4.6-2.7.amzn1.x86_64