ALAS-2021-1525


Amazon Linux AMI Security Advisory: ALAS-2021-1525
Advisory Release Date: 2021-09-02 22:54 Pacific
Advisory Updated Date: 2021-09-08 18:43 Pacific
Severity: Medium
References: CVE-2021-22924 

Issue Overview:

A flaw was found in libcurl in the way libcurl handles previously used connections without accounting for 'issuer cert' and comparing the involved paths case-insensitively. This flaw allows libcurl to use the wrong connection. The highest threat from this vulnerability is to confidentiality. (CVE-2021-22924)


Affected Packages:

curl


Issue Correction:
Run yum update curl to update your system.

New Packages:
i686:
    curl-debuginfo-7.61.1-12.99.amzn1.i686
    libcurl-7.61.1-12.99.amzn1.i686
    libcurl-devel-7.61.1-12.99.amzn1.i686
    curl-7.61.1-12.99.amzn1.i686

src:
    curl-7.61.1-12.99.amzn1.src

x86_64:
    curl-7.61.1-12.99.amzn1.x86_64
    curl-debuginfo-7.61.1-12.99.amzn1.x86_64
    libcurl-7.61.1-12.99.amzn1.x86_64
    libcurl-devel-7.61.1-12.99.amzn1.x86_64