ALAS-2021-1526


Amazon Linux AMI Security Advisory: ALAS-2021-1526
Advisory Release Date: 2021-09-02 22:54 Pacific
Advisory Updated Date: 2021-09-08 18:45 Pacific
Severity: Important
References: CVE-2021-27219 

Issue Overview:

An issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption. (CVE-2021-27219)


Affected Packages:

glib2


Issue Correction:
Run yum update glib2 to update your system.

New Packages:
i686:
    glib2-debuginfo-2.36.3-5.22.amzn1.i686
    glib2-devel-2.36.3-5.22.amzn1.i686
    glib2-fam-2.36.3-5.22.amzn1.i686
    glib2-2.36.3-5.22.amzn1.i686

noarch:
    glib2-doc-2.36.3-5.22.amzn1.noarch

src:
    glib2-2.36.3-5.22.amzn1.src

x86_64:
    glib2-2.36.3-5.22.amzn1.x86_64
    glib2-devel-2.36.3-5.22.amzn1.x86_64
    glib2-fam-2.36.3-5.22.amzn1.x86_64
    glib2-debuginfo-2.36.3-5.22.amzn1.x86_64