ALAS-2021-1530


Amazon Linux AMI Security Advisory: ALAS-2021-1530
Advisory Release Date: 2021-09-02 22:54 Pacific
Advisory Updated Date: 2021-09-08 19:17 Pacific
Severity: Important
References: CVE-2020-36328 

Issue Overview:

A flaw was found in libwebp in versions before 1.0.1. A heap-based buffer overflow in function WebPDecodeRGBInto is possible due to an invalid check for buffer size. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2020-36328)


Affected Packages:

libwebp


Issue Correction:
Run yum update libwebp to update your system.

New Packages:
i686:
    libwebp-0.3.0-10.7.amzn1.i686
    libwebp-java-0.3.0-10.7.amzn1.i686
    libwebp-debuginfo-0.3.0-10.7.amzn1.i686
    libwebp-devel-0.3.0-10.7.amzn1.i686
    libwebp-tools-0.3.0-10.7.amzn1.i686

src:
    libwebp-0.3.0-10.7.amzn1.src

x86_64:
    libwebp-tools-0.3.0-10.7.amzn1.x86_64
    libwebp-devel-0.3.0-10.7.amzn1.x86_64
    libwebp-0.3.0-10.7.amzn1.x86_64
    libwebp-debuginfo-0.3.0-10.7.amzn1.x86_64
    libwebp-java-0.3.0-10.7.amzn1.x86_64