CVE-2016-10012

Public on 2017-10-03
Modified on 2017-10-03
Description
It was found that the boundary checks in the code implementing support for pre-authentication compression could have been optimized out by certain compilers. An attacker able to compromise the privilege-separated process could possibly use this flaw for further attacks against the privileged monitor process.
Severity
Low
CVSS v3 Base Score
4.2
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 1 openssh 2017-10-03 11:00 ALAS-2017-898

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv2 3.6 AV:N/AC:H/Au:S/C:P/I:P/A:N
Amazon Linux CVSSv3 4.2 CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
NVD CVSSv2 7.2 AV:L/AC:L/Au:N/C:C/I:C/A:C
NVD CVSSv3 7.8 CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H