CVE-2017-11166

Public on 2020-06-23
Modified on 2020-10-22
Description
The ReadXWDImage function in coders\xwd.c in ImageMagick 7.0.5-6 has a memory leak vulnerability that can cause memory exhaustion via a crafted length (number of color-map entries) field in the header of an XWD file.
Severity
Low
CVSS v3 Base Score
6.5
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 ImageMagick 2020-10-22 17:05 ALAS2-2020-1497
Amazon Linux 1 php-pecl-imagick 2020-06-23 07:03 ALAS-2020-1391

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 6.5 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
NVD CVSSv2 7.1 AV:N/AC:M/Au:N/C:N/I:N/A:C
NVD CVSSv3 6.5 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H