CVE-2017-12154

Public on 2017-10-26
Modified on 2017-10-26
Description
Linux kernel built with the KVM visualization support (CONFIG_KVM), with nested visualization (nVMX) feature enabled (nested=1), is vulnerable to a crash due to disabled external interrupts. As L2 guest could access (r/w) hardware CR8 register of the host(L0). In a nested visualization setup, L2 guest user could use this flaw to potentially crash the host(L0) resulting in DoS.
Severity
Important
CVSS v3 Base Score
5.8
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 1 kernel 2017-10-26 16:43 ALAS-2017-914

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv2 4.3 AV:A/AC:H/Au:S/C:N/I:N/A:C
Amazon Linux CVSSv3 5.8 CVSS:3.0/AV:A/AC:H/PR:L/UI:N/S:C/C:N/I:N/A:H
NVD CVSSv2 3.6 AV:L/AC:L/Au:N/C:P/I:P/A:N
NVD CVSSv3 7.1 CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N