CVE-2017-15124

Public on 2018-06-07
Modified on 2018-06-11
Description
VNC server implementation in Quick Emulator (QEMU) was found to be vulnerable to an unbounded memory allocation issue, as it did not throttle the framebuffer updates sent to its client. If the client did not consume these updates, VNC server allocates growing memory to hold onto this data. A malicious remote VNC client could use this flaw to cause DoS to the server host.
Severity
Low
CVSS v3 Base Score
3.5
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 qemu-kvm 2018-06-07 23:41 ALAS2-2018-1034
Amazon Linux 1 qemu-kvm 2018-06-08 18:29 ALAS-2018-1034

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv2 2.1 AV:N/AC:H/Au:S/C:N/I:N/A:P
Amazon Linux CVSSv3 3.5 CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:N/A:L
NVD CVSSv2 7.8 AV:N/AC:L/Au:N/C:N/I:N/A:C
NVD CVSSv3 7.5 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H