CVE-2018-16842

Public on 2019-01-21
Modified on 2019-02-18
Description
Curl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer over-read in the tool_msgs.c:voutf() function that may result in information exposure and denial of service.
Severity
Low
CVSS v3 Base Score
3.6
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 curl 2019-02-16 00:34 ALAS2-2019-1162
Amazon Linux 1 curl 2019-01-21 23:46 ALAS-2019-1148

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 3.6 CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:L
NVD CVSSv2 6.4 AV:N/AC:L/Au:N/C:P/I:N/A:P
NVD CVSSv3 9.1 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H