CVE-2018-16884

Public on 2019-01-23
Modified on 2019-01-25
Description
A flaw was found in the Linux kernel's NFS41+ subsystem. NFS41+ shares mounted in different network namespaces at the same time can make bc_svc_process() use wrong back-channel IDs and cause a use-after-free vulnerability. Thus a malicious container user can cause a host kernel memory corruption and a system panic. Due to the nature of the flaw, privilege escalation cannot be fully ruled out.
Severity
Important
CVSS v3 Base Score
6.5
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 kernel 2019-01-23 23:20 ALAS2-2019-1149
Amazon Linux 1 kernel 2019-01-25 02:26 ALAS-2019-1149

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 6.5 CVSS:3.0/AV:A/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:H
NVD CVSSv2 6.7 AV:A/AC:L/Au:S/C:P/I:P/A:C
NVD CVSSv3 8.0 CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H