CVE-2019-10650

Public on 2020-06-23
Modified on 2020-10-22
Description
In ImageMagick 7.0.8-36 Q16, there is a heap-based buffer over-read in the function WriteTIFFImage of coders/tiff.c, which allows an attacker to cause a denial of service or information disclosure via a crafted image file.
Severity
Low
CVSS v3 Base Score
5.5
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 ImageMagick 2020-10-22 17:05 ALAS2-2020-1497
Amazon Linux 1 php-pecl-imagick 2020-06-23 07:03 ALAS-2020-1391

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 5.5 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
NVD CVSSv2 5.8 AV:N/AC:M/Au:N/C:P/I:N/A:P
NVD CVSSv3 8.1 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H