CVE-2019-15692

Public on 2020-10-22
Modified on 2021-01-13
Description
TigerVNC version prior to 1.10.1 is vulnerable to heap buffer overflow. Vulnerability could be triggered from CopyRectDecoder due to incorrect value checks. Exploitation of this vulnerability could potentially result into remote code execution. This attack appear to be exploitable via network connectivity.
Severity
Medium
CVSS v3 Base Score
7.2
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 tigervnc 2020-10-22 18:47 ALAS2-2020-1552
Amazon Linux 1 tigervnc 2021-01-12 22:52 ALAS-2021-1470

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 7.2 CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
NVD CVSSv2 6.5 AV:N/AC:L/Au:S/C:P/I:P/A:P
NVD CVSSv3 7.2 CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H