CVE-2020-14350

Public on 2020-10-26
Modified on 2020-10-27
Description
A flaw was found in PostgreSQL, where some PostgreSQL extensions did not use the search_path safely in their installation script. This flaw allows an attacker with sufficient privileges to trick an administrator into executing a specially crafted script during the extension's installation or update. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Severity
Medium
CVSS v3 Base Score
7.1
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 1 postgresql96 2020-10-26 18:29 ALAS-2020-1443
Amazon Linux 1 postgresql95 2020-10-26 18:27 ALAS-2020-1442

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 7.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
NVD CVSSv2 4.4 AV:L/AC:M/Au:N/C:P/I:P/A:P
NVD CVSSv3 7.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H