CVE-2021-30465

Public on 2021-05-14
Modified on 2021-12-01
Description
The runc package is vulnerable to a symlink exchange attack whereby an attacker can request a seemingly innocuous container configuration that results in the host filesystem being bind-mounted into the container. The highest threat from this vulnerability is to data confidentiality and integrity as well as to system availability.
Severity
Important
CVSS v3 Base Score
7.5
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 runc 2021-10-19 20:33 ALAS2DOCKER-2021-008
Amazon Linux 2 runc 2021-10-19 20:32 ALAS2NITRO-ENCLAVES-2021-008
Amazon Linux 1 runc 2021-05-14 16:52 ALAS-2021-1499

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 7.5 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
NVD CVSSv2 6.0 AV:N/AC:M/Au:S/C:P/I:P/A:P
NVD CVSSv3 8.5 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H