CVE-2021-3177

Public on 2021-02-19
Modified on 2021-02-24
Description
A flaw was found in python. A stack-based buffer overflow was discovered in the ctypes module provided within Python. Applications that use ctypes without carefully validating the input passed to it may be vulnerable to this flaw, which would allow an attacker to overflow a buffer on the stack and crash the application. The highest threat from this vulnerability is to system availability.
Severity
Medium
CVSS v3 Base Score
5.9
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 python3 2021-02-19 01:27 ALAS2-2021-1611
Amazon Linux 2 python 2021-02-19 01:27 ALAS2-2021-1611
Amazon Linux 1 python38 2021-02-23 20:18 ALAS-2021-1484
Amazon Linux 1 python27 2021-02-23 20:18 ALAS-2021-1484
Amazon Linux 1 python36 2021-02-23 20:18 ALAS-2021-1484

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
NVD CVSSv2 7.5 AV:N/AC:L/Au:N/C:P/I:P/A:P
NVD CVSSv3 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H