CVE-2017-3167

Public on 2017-08-03
Modified on 2017-09-14
Description
It was discovered that the use of httpd's ap_get_basic_auth_pw() API function outside of the authentication phase could lead to authentication bypass. A remote attacker could possibly use this flaw to bypass required authentication if the API was used incorrectly by one of the modules used by httpd.
Severity
Medium
CVSS v3 Base Score
7.4
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 1 httpd 2017-09-13 22:50 ALAS-2017-892
Amazon Linux 1 httpd24 2017-08-03 18:53 ALAS-2017-863

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 7.4 CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
NVD CVSSv2 7.5 AV:N/AC:L/Au:N/C:P/I:P/A:P
NVD CVSSv3 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H