CVE-2019-6978

Public on 2019-03-07
Modified on 2020-10-22
Description
The GD Graphics Library (aka LibGD) 2.2.5 has a double free in the gdImage*Ptr() functions in gd_gif_out.c, gd_jpeg.c, and gd_wbmp.c. NOTE: PHP is unaffected.
Severity
Low
CVSS v3 Base Score
5.3
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 libwmf 2020-10-22 18:24 ALAS2-2020-1533
Amazon Linux 2 libwmf 2019-03-07 06:01 ALAS2-2019-1174
Amazon Linux 2 libwmf 2020-10-22 18:24 ALAS2-2020-1533
Amazon Linux 2 libwmf 2019-03-07 06:01 ALAS2-2019-1174
Amazon Linux 1 libwmf 2019-03-21 18:35 ALAS-2019-1174

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 5.3 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
NVD CVSSv2 7.5 AV:N/AC:L/Au:N/C:P/I:P/A:P
NVD CVSSv3 9.8 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H