CVE-2020-36328

Public on 2021-07-01
Modified on 2021-09-08
Description
A flaw was found in libwebp. A heap-based buffer overflow in functions WebPDecode*Into is possible due to an invalid check for buffer size. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Severity
Important
CVSS v3 Base Score
9.8
See breakdown

Affected Packages

Platform Package Release Date Advisory
Amazon Linux 2 libwebp 2021-07-01 01:01 ALAS2-2021-1676
Amazon Linux 2 qt5-qtimageformats 2021-07-01 01:05 ALAS2-2021-1679
Amazon Linux 1 libwebp 2021-09-02 22:54 ALAS-2021-1530

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD CVSSv2 7.5 AV:N/AC:L/Au:N/C:P/I:P/A:P
NVD CVSSv3 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H